Beantwoorden
gargle
Professional Beetjesweter
Berichten: 8
Alles op zijn plek! Jij bent af! Follow the reader, reader! Leesbeest!

IPv6-storingen sinds eind oktober

Mijn twee debian computers doen een beetje raar sinds eind oktober, begin november.  Emacs heeft problemen om elpa.gnu.org te bereiken voor package updates.  Ik gebruik emacs ook als mastodon client om floss.social te contacteren via het package mastodon.el.  Ik heb mastodon.el ergens in september geconfiguurd en toen werkte alles.  Nu echter werkt mastodon.el niet meer.  Beide connecities gaan via poort 443.  Via firefox is er geen probleem.  Ik kan elpa.gnu.org bereiken.  https://floss.social/home  in firefox werkt ook normaal.
Ik heb zo'n Docsis 3.1 E-router (docsis) zonder wifi en heb een tp-link archer c2 ac750 met openwrt.  Bridging staat aan en ik heb het mac address van de tp-link router ingebracht.  De configuratie staat zo al sinds september 2021 ongewijzigd en heeft altijd gewerkt.

Mijn debian computers hebben deze configuratie:

root@msi:/home/gargle/whoami# cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*
# The loopback network interface
auto loiface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp

 

 

Ik krijg een ipv4 en ipv6 adres, maar gnutls heeft een lange tijd nodig om elpa.gnu.org te contacteren.  Wanneer ik gnutls-cli 'time' kost het 2 minuten 35 voor het afgelopen is.

Doe ik dit dan werkt alles, maar dan zit ik dus enkel op ipv4:
root@msi:/home/gargle# /sbin/sysctl -w net.ipv6.conf.all.disable_ipv6=1net.ipv6.conf.all.disable_ipv6 = 1
root@msi:/home/gargle# /sbin/sysctl -w net.ipv6.conf.default.disable_ipv6=1net.ipv6.conf.default.disable_ipv6 = 1

 

 

Ik heb dus wel een work around, maar ik vraag me echt af wat er gebeurd is twee weken geleden.  Waarom werkt mijn configuratie plots niet meer?  Mijn laptop van het werk draait windows 10 met wsl2 en debian, en daar heb ik geen enkel probleem.

Zijn er hier nog mensen met dit probleem?  Heeft telenet iets gewijzigd waar debian gevoelig voor is?

Titel gewijzigd door Christof (mod) | Vorige titel: problemen met ipv6 sinds eind oktober, ben ik alleen?

0 Likes
4 reacties
Master-Magic
Professional Superweter
Berichten: 5473
Professional organizer! PhD in problem solving! Organisatietalent! Topic held(in)!

IPv6-storingen sinds eind oktober

@gargle 

Herstart de Telenet modem/router eens en je eigen router, soms helpt dit, heb dit ook nog moeten doen en bij andere klanten hier hielp dit ook, je kan maar proberen.


   Master-Magic | Krak
    https://www.master-magic.be
      Vergeet niet om likes te geven en/of als oplossing te markeren.
Ex-Netweter
 

IPv6-storingen sinds eind oktober


@gargle  schreef:

Heeft telenet iets gewijzigd waar debian gevoelig voor is?

Totaal geen idee, maar de IT-wereld en Telenet veranderen continu. Uit je post blijkt dat je nog niet de juiste tests gedaan hebt om Telenet als oorzaak uit te sluiten.

DNS misschien? Gebruik eens een andere DNS-server.
Probeer eens te connecteren met je Debian-pc via een andere ISP (4G, DSL, fiber) of via een VPN die IPv6 ondersteunt.
Start eens op van een Debian Live USB, test je snelheid eens via https://ipv6-test.com/

0 Likes
gargle
Professional Beetjesweter
Berichten: 8
Alles op zijn plek! Jij bent af! Follow the reader, reader! Leesbeest!

IPv6-storingen sinds eind oktober

Done.  Reboot van de modem, en alles werkt terug zoals het moet.  Ik heb niks aan mijn openwrt moeten wijzigen, noch aan mijn debian config.  gnutls-cli doet er nu maar 20 seconden over en connecteert op het ipv6 adres.  Cool!

gargle
Professional Beetjesweter
Berichten: 8
Alles op zijn plek! Jij bent af! Follow the reader, reader! Leesbeest!

IPv6-storingen sinds eind oktober

test-ipv6.com geeft nu ook terug een 10/10.