Beantwoorden
WouterC
Experienced Weetjesweter
Berichten: 12
Dat loopt vlotjes. TV-box / TV-app / telenttv.be Nog geen reader's digest? :-) A born reader!

Hoe ipv6-adres achter OpenWrt-firewall verkrijgen?

Dag allen,

Ik heb al enige tijd een CV8560E modem, maar heb vandaag pas tijd gevonden om een eigen firewall op te zetten. Ik gebruik nu OpenWrt (22.03.0-rc3).

Geen enkel toestel achter de OpenWrt firewall krijgt een ipv6 adres. Alle interfaces op de firewall hebben een ipv6 adres.

Ipv4 werkt normaal en het mac-adres van de firewall in ingesteld in mijn.telenet.

 

Kan iemand zijn werkende OpenWrt config eens posten? Ik heb al vanalles geprobeerd, maar ik krijg ipv6 op mijn LAN niet werkende. 

 

Titel gewijzigd door Lieselot91 (mod) | Vorige titel: Openwrt, LAN en ipv6

0 Likes
6 reacties
Arnie
Experienced Allesweter
Berichten: 1417
Krak 2021 Krak 2022 Krak Boek alvast het Sportpaleis!

Hoe ipv6-adres achter OpenWrt-firewall verkrijgen?

Misschien kan @NofanTasi hier mee helpen. Volgens mij gebruikt hij ook openwrt. Ik heb zelf geen openwrt ervaring.

Je schrijft dat de verschillende interfaces van je router een IPv6 adres hebben. Is dit wellicht enkel een link-local adres (startend met fe80), maar geen publiek/global adres (startend met 2a02) ?

De IPv6 config kan heel eenvoudig zijn. De WAN interface ontvangt zodra IPv6 geactiveerd is normaal gesproken via SLAAC/RA een publiek IPv6 adres, waarna het mogelijk zal zijn om vanaf de router zelf een ping6 uit te voeren naar hosts op het internet.

Om binnen het eigen netwerk ook adressen te kunnen uitreiken dient de router ook Prefix-Delegation te gebruiken. Op de WAN interface moet DHCPv6 geactiveerd worden, zodat de router een prefix zal aanvragen.

 

network.wan6=interface
network.wan6.device='eth1'
network.wan6.proto='dhcpv6'

 

 

Op de LAN interfaces moet IPv6 geactiveerd worden, zodat de router adressen kan uitdelen.\

PS. De bridge functie van de CV8560E staat volledig los van IPv6. Deze heeft enkel betrekking op IPv4.

 

 

 


   Arnie | Krak
   Meten is weten. Gissen is missen.
    Vergeet niet om likes te geven en/of als oplossing te markeren.
NofanTasi
Freshman Bijna Allesweter
Berichten: 470
Meer goede raad dan tante Kaat Opgeruimd staat netjes! Lees je nog iets anders? ;-) WOW!

Hoe ipv6-adres achter OpenWrt-firewall verkrijgen?

@WouterC

Ik ben op vakantie en reageer misschien pas volgende week uitgebreider.

Ook: onze setup is met vast IP adres, achter Telenet modem-only toestel.

@Arnie vat de configuratie goed samen voor IPv6 : ontvang adres en range en delegeer.

Zelf wijk ik af in dat ik een kleine extra gentoo server heb voor DHCP, DNS en router v6 advertisements en nog wat klassieke LAN server functionalitiet.

Hier op reis (Frankrijk) heb ik een OpenWRT roaming mobile hotspot met v4 en v6 werkende.

Misschien kan ik je die configuratie sturen maar ook deze wijkt, vanwege specifieke gepersonaliseerde extras, ongetwijfeld af van wat je precies wenst.

{*niet* 'like'-en aub}
0 Likes
NofanTasi
Freshman Bijna Allesweter
Berichten: 470
Meer goede raad dan tante Kaat Opgeruimd staat netjes! Lees je nog iets anders? ;-) WOW!

Hoe ipv6-adres achter OpenWrt-firewall verkrijgen?

@WouterC : zie onze PM en (ook voor anderen) je eigen https://forum.openwrt.org/t/no-ipv6-on-lan-hosts/130019

{*niet* 'like'-en aub}
0 Likes
WouterC
Experienced Weetjesweter
Berichten: 12
Dat loopt vlotjes. TV-box / TV-app / telenttv.be Nog geen reader's digest? :-) A born reader!

Hoe ipv6-adres achter OpenWrt-firewall verkrijgen?

Met hulp van de OpenWrt community en NofanTasi werkt het nu. 
Hieronder mijn config. (OpenWrt 22.03.0-rc4)

 

/etc/config/network:
```
...
config interface 'lan'
option device 'br-lan'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
...
config interface 'wan'
option device 'eth0'
option proto 'dhcp'

config interface 'wan6'
option device 'eth0'
option proto 'dhcpv6'
...
```

/etc/config/dhcp
```
config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option nonwildcard '1'
option localservice '1'
option ednspacket_max '1232'
option rebind_protection '1'

config dhcp 'lan'
option interface 'lan'
option dhcpv4 'server'
option dhcpv6 'server'
option ra 'server'
list ra_flags 'managed-config'
list ra_flags 'other-config'
option start '50'
option limit '200'

config dhcp 'wan'
option interface 'wan'
option ignore '1'

config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
```

NofanTasi
Freshman Bijna Allesweter
Berichten: 470
Meer goede raad dan tante Kaat Opgeruimd staat netjes! Lees je nog iets anders? ;-) WOW!

Hoe ipv6-adres achter OpenWrt-firewall verkrijgen?

@WouterC : misschien is het handig, specifiek voor andere Telenet gebruikers met vergelijkbare setup, om enkel de specifieke minimale wijzigingen samen te vatten die de configuratie doen werken ...

{*niet* 'like'-en aub}
0 Likes
WouterC
Experienced Weetjesweter
Berichten: 12
Dat loopt vlotjes. TV-box / TV-app / telenttv.be Nog geen reader's digest? :-) A born reader!

Hoe ipv6-adres achter OpenWrt-firewall verkrijgen?

Op vraag van NofanTasi:

config dhcp 'lan'
  option interface 'lan'
  option dhcpv4 'server'
  option dhcpv6 'server'
  option ra 'server'
  list ra_flags 'managed-config'
  list ra_flags 'other-config'