De Netweters
annuleren
Resultaten voor 
Zoek in plaats daarvan naar 
Bedoelde u: 

Grohe Sense geen connectie na bridging (CV8560E)

Beantwoorden
nickw
Experienced Weetjesweter
Berichten: 33
Tien op tien! On a roll... Nog geen reader's digest? :-) Nice talking to you!

@Steven-E  schreef:

Ik heb in "Mijn Telenet" deze config bij "geavanceerde instellingen".

Misschien moet je daar eens mee spelen.

Screenshot 2021-01-22 at 16.24.13.png

 

Nope, geen resultaat

0 Likes
Beantwoorden
nickw
Experienced Weetjesweter
Berichten: 33
Tien op tien! On a roll... Nog geen reader's digest? :-) Nice talking to you!

Deze nacht verloor de e-router verbinding.

 

Dit heeft er mijns inziens voor gezorgd dat als mijn eigen router verbonden is op de e-router als bridge/switch (wireless access point), mijn Grohe Sense water sensors nu negen van de tien keer niet verbinden met Grohe's Cloud (Errorcode: 10). Daarenboven, wanneer de verbinding wel die ene keer lukt, dan meldt de Sense app me na enkele uren dat mijn watersensors offline zijn gegaan.

 

Mijn tabel ziet er dus nu als volgt uit:

 

 

e-router bridged wan mac address eigen router | wan poort

e-router bridged lan mac address eigen router | wan poort

e-router niet bridged | lan poort

e-router niet bridged | wan poort

TP-Link (router) + Aimesh (ap, wifi mixed)

Nee

Nee

 

Nee

TP-Link (router, wifi 2.4ghz)

Nee

Nee

 

Nee

TP-Link (ap, wifi 2.4ghz)

 

 

Nee (Niet meer)

 

 

Vandaag heb ik terug antwoord gekregen van de Grohe support. Men vroeg mij het volgende te proberen:

 

Can you do another test if possible? Do you have a 2nd smartphone? If so, can you activate its hotspot and see if you are able to connect the device to the internet through the hotspot of the 2nd smartphone?

 

Dit werkte meteen, als ware het een-twee-drie hoplá. De verbinding ging super snel.

 

Mijn vraag nu is, blokkeert Telenet enkele cruciale zaken aan hun zijde?

0 Likes
Beantwoorden
Steven-E
Experienced Allesweter
Berichten: 1417
Hallo zeg! Wat weet jij niet? Happy New Year! Like a journalist. Volop in the game!

Begrijp ik het goed dat je je watersensors opnieuw hebt ingesteld dmv de Grohe app, nu geïnstalleerd op een andere Smartphone. En dat alles sindsdien stabiel werkt?

 

PS: meerdere CV8560e modems zijn vannacht herstart, ook de mijne.

Ik vermoed dat Telenet een software upgrade heeft uitgerold.


  Steven-E | Krak
  Ik wil groot zijn in iets kleins
  Vergeet niet om likes te geven en/of als oplossing te markeren.
0 Likes
Beantwoorden
Arnie
Freshman Bijna Allesweter
Berichten: 489
De race is begonnen! Waar zijn die handjes? Happy New Year! Lezersgoud. Respect!

@Steven-E  ik begrijp de bijdrage anders; als hij de watersensor verbind met een wifi hotspot (gsm tethering) dan connecteren ze probleemloos met Grohe, en zijn zichtbaar vanuit de app (andere gsm).

 

De watersensor verbinden zich goed als ze verbonden zijn achter een eigen router, achter een modem-only.

Ze connecteren niet achter diezelfde eigen router, als deze verbonden is met een e-router (met MAC-passthrough geconfigureerd).

 

De resultaten via een AP direct verbonden aan de e-router lijken wisselend te zijn, maar misschien lag dat aan de test.

 

Het zou interessant meer informatie (sniffer trace) te zien van het type verkeer wat de watersensor verstuurd, en als antwoord terug verwacht. Volgens de dokumentatie is de connectie van de sensors naar de Grohe Cloud IPv4 gebasseerd, gebruikmakend van de poorten 80 en/of 443 (uitgaand). Niets bijzonders dus, zou je denken.



Meten is weten. Gissen is missen.
Beantwoorden
nickw
Experienced Weetjesweter
Berichten: 33
Tien op tien! On a roll... Nog geen reader's digest? :-) Nice talking to you!

@Steven-E 

Nee, je begrijpt het niet goed. Mijn excuses, ik had duidelijker moeten zijn.

 

Hetgeen ik moest doen van de Grohe support was:

 

Op een andere smartphone(*) de wifi verbinding uitschakelen zodat die enkel gebruik maakt van zijn mobiele data. Op diezelfde smartphone een persoonlijke wifi hotspot instellen om vervolgens mijn smartphone daarmee te verbinden en de connectie van de watersensors uit te proberen.

 

Dit werkt wonderwel.

 

(*) Die andere smartphone is een iPhone. De mijne is een OnePlus. De te volgen stappen op de iPhone: https://support.apple.com/nl-be/HT204023. Ook, de iPhone heeft een mobieledataverbinding van Proximus.

 

- - -

 

Met mijn aangepaste tabel wil ik duidelijk maken dat sinds de herstart van de e-router vannacht de watersensors ook geen verbinding meer maken met Grohe Cloud wanneer mijn eigen router als bridge/switch (wireless ap) ingesteld staat. Met andere woorden, sinds die herstart is eender welke connectie met Grohe Cloud onmogelijk gebruik makende van het Telenet internetabonnement. Dit doet me serieus afvragen of Telenet aan hun zijde mogelijks het connectieproces van mijn watersensors verhinderd.

Beantwoorden
Arnie
Freshman Bijna Allesweter
Berichten: 489
De race is begonnen! Waar zijn die handjes? Happy New Year! Lezersgoud. Respect!

Met de verschillende testen hebben de sensors een ander IPv4 adres gebruikt voor hun connectie naar de Grohe Cloud.

Bij je modem-only oplossing had je een uniek publiek IPv4 adres.

Dit adres is veranderd, met het veranderen van modem-only naar de CV8560E.

In bridge mode geeft die een publiek IPv4 adres door aan je eigen router die erachter hangt. Misschien is dit adres om de één of andere reden op een blacklist beland.

Voor al het overige verkeer (niet afkomstig vanaf je eigen router MAC adres) gebruikt de e-router een ander IPv4 adres. Dit heeft gewerkt, maar inmiddels lukt dat niet.

Misschien ook inmiddels ook op de blacklist?

De connectie via de gsm-hotspot heeft terug een ander IPv4 adres. Dit werkt wel.

 

Heeft Grohe support naar je IP adres gevraagd of naar een andere identificatie van je sensors? Zij zouden misschien iets in de log-files kunnen zien van je verschillende connectie-pogingen.

 



Meten is weten. Gissen is missen.
0 Likes
Beantwoorden
Steven-E
Experienced Allesweter
Berichten: 1417
Hallo zeg! Wat weet jij niet? Happy New Year! Like a journalist. Volop in the game!

Inderdaad, zo’n potentiële blacklist heb ik hier eerder ook al geopperd.

Ik kan me echt geen reden voorstellen waarom de E-router de oorzaak zou kunnen zijn. Uitgaand blokkeert Telenet ook helemaal niets.


  Steven-E | Krak
  Ik wil groot zijn in iets kleins
  Vergeet niet om likes te geven en/of als oplossing te markeren.
Beantwoorden
nickw
Experienced Weetjesweter
Berichten: 33
Tien op tien! On a roll... Nog geen reader's digest? :-) Nice talking to you!

@Arnie 

Thanks.

Nee, hebben ze nog niet naar gevraagd.

 

ipv4 blacklisting-hypothese

 

Ik wacht hun volgende supportmail af en zal in mijn antwoord erop gewag maken van je bevindingen door je laatste bericht eraan toe te voegen. Immers dat bericht geeft de denkpiste keurig en bondig weer.

 

Ook wens ik hierbij alle anderen te bedanken voor hun tot zoverre hulp. @Steven-E @kristofDW Top.

Beantwoorden
nickw
Experienced Weetjesweter
Berichten: 33
Tien op tien! On a roll... Nog geen reader's digest? :-) Nice talking to you!

Antwoord gekregen van Grohe support. Dat antwoord bestond uit vragen die hier reeds de revue zijn gepasseerd. Echter, eentje nog niet:

 

Do you have cameras or other devices connected to your Wi-Fi that also use bluetooth?

 

Hierop heb ik geantwoord dat ik verschillende toestellen heb die bluetooth gebruiken. Ik denk maar aan smartphones, Google Nest Protect, Honeywell Evohome, ... Heb eraan toegevoegd dat dat niet zou mogen uitmaken gezien alles voorheen netjes werkte.

 

In mijn globale antwoord heb ik aldus nadruk gelegd op de bevindingen van @Arnie en @Steven-E (mogelijke publieke ipv4 blacklisting). Ik heb Grohe support gevraagd om deze denkpiste serieus te nemen en te checken. Nu wachten op een antwoord.

 

Hoewel ik er zelf niet veel van ken, ik heb daarnet eens gekeken of mijn publieke ipv4 adres ergens geblacklist wordt. Dit komt tevoorschijn: dnsbl.spfbl.net.

0 Likes
Beantwoorden
nickw
Experienced Weetjesweter
Berichten: 33
Tien op tien! On a roll... Nog geen reader's digest? :-) Nice talking to you!

Hierbij het antwoord van Grohe support:

 

"Hello Nick,
as far as I could find out, we do not have any public IP address restrictions on our Grohe Cloud! We would restrict only if a strange high number of requests would be coming from a certain IP address (not possible for one device)

Your devices should receive from your router a Private IP address IPv4 and communicate under the Router's public IP address to the Grohe Cloud. If the devices are not getting the private network configuration required from your router, then they will not be able to connect to the Grohe Cloud and the app message above is displayed during integration.
If you say that the devices are connecting when using a "Hotspot" connection (e.g. another phone), this indicates that the issue should be something within your network's configuration or environment."

 

Vervolgens heb ik hun gevraagd of een logbestand tot de mogelijkheden zou behoren teneinde het probleem te kunnen tackelen. Ik wacht op Grohe's antwoord.

0 Likes
Beantwoorden
Arnie
Freshman Bijna Allesweter
Berichten: 489
De race is begonnen! Waar zijn die handjes? Happy New Year! Lezersgoud. Respect!

Hopelijk kunnen zij zien of er iets bij hun toekomt. Lokaal weet ik het verder ook niet meer.

Al je andere devices achter je eigen router ontvangen correct een IPv4 adres, netmask, gateway en DNS informatie en kunnen vervolgens op het internet surfen (port 80 http en port 443 https).

Volgens de dokumentatie is dat ook precies wat je sensors nodig hebben.

We kunnen niet in de sensors kijken wat ze precies ontvangen, maar via ping kun je in ieder geval bevestigen dat ze een IPv4 adres ontvangen hebben. Eigenlijk lijkt dat dus in orde.

 

Probeer anders eens een factory reset van de CV8560E, door de reset toets 8 sekonden gedrukt te houden (tot de leds blinken). Als het goed is ontvang je dan voor je eigen router een nieuw IPv4 adres. Zo was het bij mij toch.

Eens zien of dat helpt. Controleer vooraf en achteraf even het IPv4 adres toegekend aan de wan port van je eigen router, of check dit via een site zoals https://www.watismijnip.be/

Gewoon om te zien of dit echt veranderd is.

 

Anders is het toch nodig het verkeer echt te analyseren met een sniffer programma, om te zien wat voor pakketjes verstuurd en ontvangen worden.



Meten is weten. Gissen is missen.
0 Likes
Beantwoorden
Arnie
Freshman Bijna Allesweter
Berichten: 489
De race is begonnen! Waar zijn die handjes? Happy New Year! Lezersgoud. Respect!

Voor de geinteresseerden, @nickw heeft me een wireshark trace toegestuurd.

Deze toont aan dat er bij het opbouwen van de encrypted verbinding iets fout gaat. Ik weet nog niet wat.

We zien in ieder geval een correcte DNS aanvraag, met een antwoord. De Grohe-Cloud service blijkt bij Amazon AWS gehost te zijn.

Vervolgens is er een TLSv1.2 "client hello", gevolgd door een "server hello" antwoord en een certificate en key-exchange. Hierbij / hierna gaat dan schijnbaar iets mis, waardoor de verbinding verbroken wordt "encryption alert".

Ik heb hier de oorzaak nog niet van kunnen vinden, maar kan nog altijd niet verklaren hoe de CV8560E hier de oorzaak van zou kunnen zijn. We weten nu wel dat een correct werkende IPv4 connectiviteit aanwezig is tussen de sensor en de cloud.

 

Misschien toch inderdaad het resultaat van het publieke adres op een blacklist, waardoor de encrypted verbinding niet tot stand kan komen?

@nickw, misschien kun je eens de reputatie van je externe IP adres bekijken via:

https://www.akamai.com/us/en/clientrep-lookup/



Meten is weten. Gissen is missen.
Beantwoorden
Steven-E
Experienced Allesweter
Berichten: 1417
Hallo zeg! Wat weet jij niet? Happy New Year! Like a journalist. Volop in the game!

TLS handshakes die mislopen, daar is de CV8560E wellicht niet de oorzaak van.

 

Als ik even kijk naar mijn eigen Palo Alto Networks firewall: die kan TLS/SSL verkeer onderscheppen en decrypteren (en weer decrypteren, man in the middle), om zo in de data te kunnen kijken (om applicaties te herkennen en bij malware tegen te houden).   Een TP-Link router doet dit hoogst waarschijnlijk niet.

Stel dat die dat wel zou doen, dan worden er tijdens de TLS handshake een aantal parameters genegotiëerd: gebruikte cypher suites, hashing algoritmes, enz.   Op mijn firewall kan ik bepaalde parameters aan- en uitzetten, en de andere kant (de webserver) daar kan dit ook.

Potentiëel kan het dus gebeuren dat tijdens de TLS handshake geen overeenkomst kan gevonden worden omdat de zaken die aan staan aan de ene kant, uit staan aan de andere kant (en omgekeerd). In dat geval zal de TLS handshake falen.

 

Er worden ook andere zaken gecheckt (en mijn Palo Alto doet dit zelfs zonder dat je decrypteert omdat deze zaken meestal in "clear text" in het certificaat staan) zoals:

- de geldigheid van het certificaat (start- en einddatum)

- wie heeft het certificaat uitgegeven (welke CA heeft het certificaat van de webserver getekend)

 

Mijn firewall heeft, net als een browser, een lijst van vertrouwde certificate authorities (CA's).

Die moet regelmatig worden geupdate, want regelmatig komen en verdwijnen er CA's.

Als ik de CA check aanzet op de Palo Alto, en er wordt naar een website gesurfd met een certificaat getekend door een CA die niet in de trusted lijst staat, zal mijn firewall ook deze sessies niet opzetten.

 

Dit zijn settings die je doorgaans enkel op corporate firewalls vindt, maar op basis van de info van @Arnie  denk ik toch in die richting.  @nickw check eens of je op je TP-Link router settings vindt die hieraan kunnen gerelateerd zijn?  Welke type heb je trouwens en welke software versie?

 


  Steven-E | Krak
  Ik wil groot zijn in iets kleins
  Vergeet niet om likes te geven en/of als oplossing te markeren.
0 Likes
Beantwoorden
Arnie
Freshman Bijna Allesweter
Berichten: 489
De race is begonnen! Waar zijn die handjes? Happy New Year! Lezersgoud. Respect!

@Steven-E, het blijft natuurlijk wel raar dat alles goed werkt wanneer de sensors zich met de cloud verbinden via een gsm-hotspot (tethering) verbinding. Daarom dat ik nog steeds denk in de richting van het source IPv4 adres. Die is dan anders.

Ik kan geen verklaring vinden dat het type router een rol zou spelen in het probleem.

 

Wellicht is @nickw het "slachtoffer", dat hij een modem heeft onvangen van Telenet met blacklisted IP adres, zoals dat nu toevallig in twee andere topcs (hier en hier) besproken wordt.

 

 

 



Meten is weten. Gissen is missen.
0 Likes
Beantwoorden
Steven-E
Experienced Allesweter
Berichten: 1417
Hallo zeg! Wat weet jij niet? Happy New Year! Like a journalist. Volop in the game!

Hey @Arnie ,

 

Wel als je al tot de TLS Handshake raakt, is dit voor mij een teken dat de piste van de blacklist minder waarschijnlijk is.

De TLS Handshake gebeurt op laag 5 van het OSI model, terwijl IP blacklists op laag 3 van toepassing zijn.  Als op laag 3 iets wordt tegengehouden, ga je nooit de hogere lagen kunnen bereiken.

https://nl.wikipedia.org/wiki/OSI-model

 

Als je via een hotspot thetert dan bypass je de router en potentiële TLS checks die daarop kunnen gebeuren.


  Steven-E | Krak
  Ik wil groot zijn in iets kleins
  Vergeet niet om likes te geven en/of als oplossing te markeren.
0 Likes
Beantwoorden